Solar Meter webserver does not respond

Jun 4, 2015 at 7:59 AM
I've had 11.4 working a year ago, and after receiving my E350 meter I downloaded 11.41.

I changed de code to niekvanprooijen's version, but now Solarmeter's website times out.

-- On my router, the Solarmeter appears in the "attached devices"list.
-- When I change Solarmeter's IP address, it also changes in "attached devices"
-- When I try to connect through port 555 inside my LAN, i get ERR_CONNECTION_TIMED_OUT
-- tried on Chrome and iPad
-- both tried on 100mbit switch and 1Gbit switch
-- replaced both Arduino and W5100

Any ideas?
Coordinator
Jun 4, 2015 at 8:40 AM
If you go back to 11.4, does the website appear?
If it does, you might have made a mistake in the code causing the arduino main loop to hang.
The website is updated in the main loop.

The 'attached devices' list in your router is handled by the W5100 in hardware. This is only configured in the Setup() function.
Jun 4, 2015 at 9:14 PM
Thanks Harold, going back made it work, I was suspecting the hardware, but it appears that niekvanprooijens version doesn't work on an UNO.
Now 11.41 works, but not with the E350. I have a Mega, but unfortunately it's broken. Anyone got Nieks code working on an UNO?